Ed Login Issue

Incident Report for HMH Platform

Resolved

This incident has been resolved. We have not observed any further impact, and all services are operating as expected. We will continue to monitor to ensure ongoing stability.
Posted Jun 01, 2026 - 15:20 EDT

Update

We have not observed a recurrence of this issue this morning and services are currently operating as expected. We will continue to monitor closely to ensure stability before marking this incident as resolved. We will provide another update if conditions change.
Posted Jun 01, 2026 - 10:37 EDT

Update

The Ed platform remains stable and users continue to access without interruption. We are continuing to closely monitor system performance to ensure stability.
Posted May 29, 2026 - 12:59 EDT

Monitoring

Some users experienced issues accessing the Ed platform earlier today. The issue has now stabilized, and users are able to access the platform. Our teams continue to monitor and investigate the system.
Posted May 29, 2026 - 10:42 EDT

Investigating

We are investigating an issue impacting access to the Ed platform, including blank pages after login and intermittent session interruptions. Our teams are continuing to investigate and work towards a resolution. This page will be updated as we know more.
Posted May 29, 2026 - 10:10 EDT
This incident affected: HMH Ed (Login).