Classcraft Service Interruption

Incident Report for HMH Platform

Resolved

Since restoring service, HMH teams have been monitoring access to Classcraft and this incident is now resolved.
Posted Nov 10, 2025 - 15:14 EST

Monitoring

Service to Classcraft has been restored. We'll continue to monitor performance for the next few hours before calling this officially resolved. Again, thank you for your patience.
Posted Nov 10, 2025 - 11:58 EST

Investigating

We are aware of an interruption impacting access to Classcraft. HMH engineering teams are currently investigating the cause and are working to restore service as quickly as possible. We will post another update as soon as more information is available. Thank you for your patience.
Posted Nov 10, 2025 - 11:45 EST
This incident affected: HMH Ed (Content and Resources).