Service Interruption on Ed

Incident Report for HMH Platform

Resolved

After monitoring performance today without any further issues, this incident is resolved. Thank you for your patience.
Posted Sep 19, 2025 - 17:11 EDT

Monitoring

We have observed recovery for all services on Ed and users should not experience any errors or delays. As a precaution, we will continue monitoring performance closely today.
Posted Sep 19, 2025 - 10:33 EDT

Identified

Our teams have confirmed some users may experience errors or slowness when loading content, including the Home, Class Overview and Discover tabs. We are working to address this issue as quickly as possible. Thank you for your patience.
Posted Sep 19, 2025 - 09:41 EDT

Investigating

Please be advised of a possible disruption on Ed. Educators and students may experience content that loads slowly or not at all. Our teams are investigating, and additional updates will be provided here. Thank you for your patience.
Posted Sep 19, 2025 - 09:05 EDT
This incident affected: HMH Ed (Content and Resources, Assignments).